Search…
Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed, Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed, Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed,
Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed, Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed, Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed,

Switch D-Link DGS-1100-16, 16 ports 10/100/1000 Gigabit Smart Switch, managed,

109.02 €
Earn 109 points
Out of stock
Notify me when available

We will send you an email as soon as the product is back in stock.

✅ Done! We will write to you as soon as it is available.
Manufacturer
D-Link
Ports
16
Warranty
99 months
View all specifications

Full specifications

Manufacturer
D-Link
Ports
16
Power
100 to 240V/AC, 50 to 60Hz
Rack mount
Yes
Others
MAC address table: 4K
Security
D-Link Safeguard; Traffic segmentation; Broadcast/Multicast/Unknown Unicast Storm Control; DoS attack prevention; SS
Management
Web-based GUI (supports IPv4/IPv6)
Weight (kg)
1.21
Consumption (W)
10 W
Warranty
99 months
Standards
RFC 768 UDP
RFC 791 IP
RFC 792 ICMP
RFC 793 TCP
RFC 826 ARP
IEEE 802.1p
RFC2236, IGMP Snooping
RFC1213 MIBII
RFC1215 MIB Traps Convention

Reviews

No reviews for this product yet. Be the first!

Reviews with “Verified purchase” are from customers who received a link after completing an order. We provide them with a free shipping code regardless of the rating. We publish all reviews except spam and insults.

Similar products

Switch D-Link DGS-1100-16V2, 16 port 10/100/1000 Gigabit Smart Switch, managed,

Switch D-Link DGS-1100-16V2, 16 port 10/100/1000 Gigabit Smart Switch, managed,

77.00 €
Earn 77 points
★★★★★ (0)
Switch D-Link DGS-1100-24V2, 24 port 10/100/1000 Gigabit Smart Switch, managed

Switch D-Link DGS-1100-24V2, 24 port 10/100/1000 Gigabit Smart Switch, managed

98.00 €
Earn 98 points
★★★★★ (0)
Switch D-Link DGS-1100-08V2, 8 port 10/100/1000 Gigabit Smart Switch, managed,

Switch D-Link DGS-1100-08V2, 8 port 10/100/1000 Gigabit Smart Switch, managed,

32.00 €
Earn 32 points
★★★★★ (0)
Switch Mikrotik CRS305-1G-4S+IN, 1xGigabit LAN, 4xSFP+ cages

Switch Mikrotik CRS305-1G-4S+IN, 1xGigabit LAN, 4xSFP+ cages

152.00 €
Earn 152 points
★★★★★ (0)
Switch MikroTik CRS112-8P-4S-IN, 8 x Gigabit Ethernet ports, 10/100/1000Mbps, 4 x SFP

Switch MikroTik CRS112-8P-4S-IN, 8 x Gigabit Ethernet ports, 10/100/1000Mbps, 4 x SFP

202.00 €
Earn 202 points
★★★★★ (0)
Cudy GS1016E Switch, 16x managed Gigabit PoE+ ports, 2x Gigabit SFP slots

Cudy GS1016E Switch, 16x managed Gigabit PoE+ ports, 2x Gigabit SFP slots

207.00 €
Earn 207 points
★★★★★ (0)
Switch ZYXEL XS1930-10, 8 port managed, 10Gb, 2xSFP, for rack mounting

Switch ZYXEL XS1930-10, 8 port managed, 10Gb, 2xSFP, for rack mounting

517.00 €
Earn 517 points
★★★★★ (0)
Switch D-Link DMS-105/E, 5 port 2.5G Multi-Gigabit

Switch D-Link DMS-105/E, 5 port 2.5G Multi-Gigabit

110.00 €
Earn 110 points
★★★★★ (0)
Switch ZYXEL GS1100-10HP, 8-port, Gigabit, PoE, 2xSFP, for rack mounting

Switch ZYXEL GS1100-10HP, 8-port, Gigabit, PoE, 2xSFP, for rack mounting

119.00 €
Earn 119 points
★★★★★ (0)
D-Link DGS-1008MP Switch, 8 port PoE 10/100/1000 Gigabit, unmanaged desktop switch

D-Link DGS-1008MP Switch, 8 port PoE 10/100/1000 Gigabit, unmanaged desktop switch

122.00 €
Earn 122 points
★★★★★ (0)
Switch D-Link DGS-1016D/E, 16 ports 10/100/1000, Desktop, rack mount

Switch D-Link DGS-1016D/E, 16 ports 10/100/1000, Desktop, rack mount

95.00 €
Earn 95 points
★★★★★ (0)
Switch D-Link GO-SW-24G/E, 24 ports 10/100/1000

Switch D-Link GO-SW-24G/E, 24 ports 10/100/1000

89.00 €
Earn 89 points
★★★★★ (0)
ZYXEL GS1900-8HP-V3 Switch, 8 port smart managed, PoE, Gigabit

ZYXEL GS1900-8HP-V3 Switch, 8 port smart managed, PoE, Gigabit

130.00 €
Earn 130 points
★★★★★ (0)
Messenger